SC3T water leak in equipment room

Incident Report for CAMRIS

Monitoring

Siemens has implemented a temporary fix and the scanner is now available for use. Siemens will return Monday evening to complete repairs, but we do not expect further issues.
Posted Feb 20, 2026 - 12:03 EST

Identified

Siemens has identified the source of the leak from their equipment. They are making repairs currently. We expect to have more information at approximately 11:30am, but for now the scanner is down.
Posted Feb 20, 2026 - 10:40 EST

Investigating

SC3T is down due to a water leak in the equipment room. Siemens is on-site and investigating the source of the leak. We will provide additional information as soon as we have it, but currently do not have an estimate of when the scanner will be back online.
Posted Feb 20, 2026 - 10:23 EST
This incident affects: Stellar Chance 3T (MRI Scanner).