Equipment room at Stellar Chance

Incident Report for CAMRIS

Resolved

This incident has been resolved.
Posted Jul 30, 2025 - 11:33 EDT

Investigating

Maintenance request placed for Stellar Chance equipment room. The space is extremely hot, and the air conditioning is not working. Service request # 952736
Posted Jul 08, 2025 - 14:55 EDT
This incident affected: Stellar Chance 3T (MRI Scanner).