PAV 10 down

Incident Report for CAMRIS

Resolved

Siemens has repaired PAV10 and is now back online.
Posted Sep 11, 2025 - 12:36 EDT

Identified

Siemens has identified a failure at PAV10 and taken the scanner offline. Parts have been ordered but we do not yet have a timeline for when PAV10 will be back online.
Posted Sep 11, 2025 - 07:10 EDT
This incident affected: PAV10 (MRI Scanner).