TriState staff performed repairs to the cooling system at Stellar Chance this afternoon. CAMRIS staff will be on-site to check the status of the scanners Monday morning. SC3T and SC7T must remain offline and fully powered off until further notice.
Posted Jun 01, 2025 - 20:03 EDT
Update
We are currently investigating a possible failure of the cooling system serving the Stellar Chance MRI scanner bays. TriState has been contacted and we will provide an update when we have more information their timeline for servicing the cooling system. SC3T and SC7T must remain offline and fully powered off until further notice.
Posted Jun 01, 2025 - 10:19 EDT
Update
SC3T and SC7T are both offline with cooling errors. Siemens is being contacted. We will provide updates when we have more information.
Posted Jun 01, 2025 - 09:14 EDT
Investigating
Remote user reported cooling errors on SC7T causing scanner to stop running. Scanner should be considered offline until further notice. CAMRIS staff will investigate further on Monday morning.
Posted May 31, 2025 - 17:20 EDT
This incident affected: Stellar Chance 3T (MRI Scanner) and Stellar Chance 7T (MRI Scanner).