Leak in SC3T Control Room Ceiling

Incident Report for CAMRIS

Resolved

Air handling for the SC3T console room has been repaired.
Posted May 26, 2026 - 15:52 EDT

Update

Facilities has discovered the leak was continuing to damage the ceiling. As a temporary remedy, the air conditioning for the SC3T control room will be turned off through Tuesday. A more permanent repair will be implemented next week. In the interim, the control room will likely be warmer than typical.
Posted May 22, 2026 - 12:35 EDT

Identified

A small leak in the SC3T control room ceiling caused water damage and sagging ceiling tiles near the door to the SC7T control room. The leak has been repaired, but the damage to the ceiling still needs to be fixed. Facilities is aware of the issue and it should be repaired by Tuesday.
Posted May 21, 2026 - 09:19 EDT
This incident affected: Stellar Chance 3T (MRI Scanner).