Leak in ceiling of Stellar 3T Control Room
Incident Report for CAMRIS
Resolved
The leak is fixed. The tile needs to be cut out for the light fixture still.
Posted Nov 06, 2024 - 16:15 EST
Investigating
There is a small leak coming from the ceiling in the 3T control room of Stellar Chance. There was a light fixture and saturated ceiling tile hanging when I walked in this morning. That is cleaned up and out of the way. FRES was called for maintenance to come out but did not give an ETA.
Posted Nov 06, 2024 - 08:39 EST