A new visual stimulus display system has been installed at SC3T and the system borrowed from SC7T has been returned. There is a working visual stimulus display system at SC7T now.
Posted Jul 13, 2026 - 17:32 EDT
Update
We are planning to return the screen to SC7T when we updated the stimulus system at SC3T. At this point we expect this to occur in late spring or early summer. We will share an exact timeline once this is finalized.
Posted Jan 22, 2026 - 06:01 EST
Identified
We are awaiting a replacement monitor for SC3T, and in the interim the monitor from SC7T has been moved to SC3T. We expect a replacement monitor will be available this summer, and will provide a more specific update once we have additional information from the manufacturer.
Posted Apr 24, 2025 - 14:40 EDT
Investigating
We are currently investigating this issue.
Posted Apr 24, 2025 - 14:39 EDT
This incident affected: Stellar Chance 7T (Visual Presentation System).