Flywheel down at PAV10

Incident Report for CAMRIS

Resolved

Dicom receiver is back up and running.
Posted Jun 12, 2025 - 09:10 EDT

Investigating

Dicom receiver is down.
Posted Jun 11, 2025 - 19:05 EDT
This incident affected: Flywheel Reaper.