Stellar Chance exam rooms and bathrooms flooded

Incident Report for CAMRIS

Update

Facilities continues to work on repairs for exam rooms and bathrooms. Currently they are both inaccessible for research groups using the scanners in Stellar Chance. We will provide an update on when they are expected to be back online once we have that information from the building manager, but we expect it will be several days from now.
Posted May 20, 2026 - 11:27 EDT

Identified

There was a water leak overnight in the Stellar Chance basement that has affected the exam rooms and bathrooms. We do not have an estimate of when these areas will be accessible.
Posted May 19, 2026 - 06:09 EDT
This incident affects: Stellar Chance 3T (MRI Scanner) and Stellar Chance 7T (MRI Scanner).