SC7T scanner screen not working

Incident Report for CAMRIS

Resolved

Incident resolved
Posted Jul 01, 2026 - 11:29 EDT

Identified

The screen above the bore that reports coil connections, table position, ... is blank. Scanner operates normally otherwise.
Posted Jun 29, 2026 - 14:59 EDT
This incident affected: Stellar Chance 7T (MRI Scanner).