SC3T back panel

Incident Report for CAMRIS

Update

Engineer will fix tomorrow 1/8.
Posted Jan 07, 2026 - 13:59 EST

Investigating

Back panel of SC3T is not attached correctly. Ticket# 400113614413. System is fully operational
Posted Jan 06, 2026 - 15:57 EST
This incident affects: Stellar Chance 3T (MRI Scanner).