SC7T 32-channel head coil mirror does not attach

Incident Report for CAMRIS

Resolved

Siemens repaired the screw mount and the SC7T head coil mirror should now attach correctly.
Posted Jul 15, 2026 - 13:44 EDT

Identified

Siemens engineer is expected on-site Wednesday morning to repair the coil.
Posted Jul 14, 2026 - 16:04 EDT

Investigating

The screw that holds the mirror for the 32-channel head coil in place has jammed. Siemens has been notified.
Posted Jul 14, 2026 - 12:17 EDT
This incident affected: Stellar Chance 7T (1Tx32Rx Head Coil).